From XiphWiki
Jump to navigation Jump to search


JoshuaRodman wrote regarding the yp-t7z:

I received such a unit. It plays oggs encodd at -q 4, 5 and 6 without error that I have noticed. However it seems underdocumented. It plays the files in an order which is neither alpha sorted nor numeric sorted, and it does not support ogg tags. -- JoshuaRodman (March 28, 2005)
I've investigated more. Some music encoded at even -q 5 will break up or cause difficulty. I suspect these pieces have bitrate spikes. As for the ordering, the YP-T7 plays files in 'readdir' order. That is it does not sort the files out of the filesystem at all. In practice, this means it will play the files in the order that you add them to the directory. If you are a windows user dragging and dropping the files onto the player, this problem will not affect you. A linux or possible Mac user may need to do minor scripting to alleviate this issue. --JoshuaRodman (April 13, 2005)
I thought I came back and clarified this, but don't have hte energy to review the edit history. In any event, there are no problems with OGG playback on my YP-T7z at this time. All symptoms have evaporated with firmware updates or magic. JoshuaRodman 01:27, 7 April 2006 (PDT)

Spaz added for the YP-T7Z:

After using the newest firmware I have had no issues playing OGG files. Any lockup or playback issues I had experienced went away. --Spaz (Dec 23, 2005)

Ulrich added for the YP-MT6Z:

I think my manual says the first 8 characters of a filename are considered for sorting. As my files have the "tracknumber" tag, I wrote some Perl script that prepends that number (two digits plus a space) to the track names when being copied onto the player. I'm not sure about decoding problems, but there may be some. I encoded my files at q6 or higher using "oggenc" from Linux. Tags for title and performer are displayed unless you follow the Vorbis specification to create one tag for each performer. However, be aware that default settings have tag display disabled!
The chip inside seems to be a Sigmatel STMP3400M, natively specified for MP3 with addon codecs.
It would be great of Samsung Europe would release firmware with release notes (the Korean site has newer firmware, but no English, really!). There's also some inoffical newer firmware around, but also without any release notes. Official firmware is 2.122 (on my player as delivered and on CD and website).
Recently I decided to remove some Ogg files from the player and add a few new ones. Unfortunately this resulted in some directories (usually structured as <artist>/<album>/<track-number> <track-title>) being unplayable. There's just a message saying "No Entry". Interestingly this happens with directories that did play before removing some files. Newer firmware didn't change anything about that. I suspect that this is caused by either 1) special characters in the file names (I use UTF-8 encoding), 2) special characters in the Vorbis comment, 3) length of file names, 4) number of files in the file system, or 5) amount of free space (my player has just 90kB free now). One symptom is that in Settings->System->About there are fewer files counted than actually exist in the filesystem. And yes, I've checked the filesystem several times. I have contacted German support, and they replied they'll investigate, but they did not ask back about any details (and support doesn't allow to reply).
With the new inofficial firmware 2.290 I had a few crashes: The player was playing a continuous tone, and the only way to stop it was to remove the battiery for a moment. However as the effect was not repeatable when playing the same file, I can believe that some mobile phone triggered that. The other thing is the fact that my player came without FM radio. The newer firmware has the radio item in firmware, but as soon as I select it, the player will hang until the battery is removed. OK, that's inofficial firmware...
--(Ulrich on 2006-02-02)
Two questions: 1) are ogg tags not being displayed even when the Tag option is toggle to On in the settings menu? 2) how does it handle -q 4 and -q 6 — is it just -q 5, or is it -q 5 and higher/lower? — Saxifrage 01:07, 14 Apr 2005 (PDT)
I have seen no evidence of vorbis tags being supported; they are not displayed. I have generally encoded at -q 5 as an attempt to stay inside the "supported" bitrate boundaries. I find that the bitrate and breakups are not directly correlated, but somewhat related. This is no surprise if the problem is CPU time exhaustion. I have not found any particular quality encoding to fail either reliably or often. In general, speeds above the stated maximum supported bitrates have seemed to work fine. No lockups of any kind have been encountered. Incidentally, over 90% of my ogg files have been processed by vorbisgain. --JoshuaRodman (July 5, 2005)

I just bought one of these and I'm baffled by its erratic Ogg support. Firmware version 1.541 seems to support tags just fine, though I haven't noticed the alpha-sorting issue (haven't looked). However, I find that it can't play all my Ogg files (freezes when it tries to load the file), and there's nothing systematic that I've found to account for this. It plays some files I encoded Jan 29-Jan 30, 2005, but there are files that don't work before and after that date. The files that work so far were encoded with nominal bitrates of 128 and 192, while others that don't work were at 160. All encodings have used the same program (Grip under Linux). Ogg files that I've encoded with oggenc directly for testing purposes at 160 nominal bitrate work just fine. There's just something about most of my existing files.

I've emailed a support request to Samsung Canada, so I'll report what I find out then. Meanwhile I'm doing a bunch of rips with Grip to test different nominal bitrates. Saxifrage 10:53, 12 Apr 2005 (PDT)

Results from my experiments with different nominal bitrates are summarised in this table:
YP-T6 Ogg Vorbis support
  Tags none tag* tag + replaygain replaygain
Bitrate (nominal)          
128   works works works ?
160   works works freezes works
192   works works works ?
* "tag" means just the regular complement of artist, album, title, year, and genre.
"?" indicates that the case was not tested
My conclusion is that the Samsung YP-T6 can't handle Ogg Vorbis files encoded at 160 nominal bitrate if ReplayGain tags are applied to the file. Note too that I tested a file without real RG tags, but with the normal tags plus tags with different names than the standard RG tags but with the same name-length and same length of arguments; this was to isolate whether it was a ReplayGain-specific bug or a general tag-handling bug. Thus, I suspect that the problem is a buffer overflow in tag code of the firmware. Note that I have only tested files encoded with nominal bitrates, not files encoded with oggenc's quality settings.
The few files in my collection that have worked were encoded at different bitrates (either 128 or 192), but unfortunately the vast majority are 160, and I need ReplayGain to be able to listen to my collection on the PC without constantly changing the volume. As a workaround I may write a script to strip the ReplayGain tags as they're moved to my player, but this rather sucks. — Saxifrage 12:36, 12 Apr 2005 (PDT)


Samsung appears to have model bumped the yp-t7 series with the yp-t7j series. The spec sheet does not mention OGG/Vorbis as a supported file format. This seems a real shame as the t7 worked well. Does anyone have anything more conclusive? JoshuaRodman 08:26, 6 January 2006 (PST)


I (Gav) own a Yepp MT-6X and I don't come to the same conclusions. I tried to remove the Gain tags and it didn't improve anything. Here are some tests I made :
YP-MT6X Ogg Vorbis support
Encoder version Filename Nominal bitrate Playback test
Xiphophorus libVorbis I 20000508 (1.0 beta 1 or beta 2) 01 - In Tenebris.ogg unset (160 kbps) KO
Xiphophorus libVorbis I 20001031 (1.0 beta 3) 01 - A Day Without Rain.ogg 160 kbps KO
Xiphophorus libVorbis I 20010225 (1.0 beta 4) 01 - Sunday Bloody Sunday.ogg 128 kbps KO
Xiphophorus libVorbis I 20010615 (1.0 rc1) 01 - Remede.ogg 128 kbps KO
Xiphophorus libVorbis I 20010813 (1.0 rc2) 01 - Devil's Haircut.ogg 192 kbps OK
Xiphophorus libVorbis I 20011231 (1.0 rc3) 01 - Encore Une Chance.ogg 112 kbps OK
Xiph.Org libVorbis I 20020717 (1.0) 01 - Inferno (Unleash The Fire).ogg 160 kbps KO
Xiph.Org libVorbis I 20030909 (1.0.1) 01 - You Will Be a Hot Dancer.ogg 128 kbps OK

Yes, a 1.0 file fails... I also tested a 8 second file encoded at q1,q2,...,q10 using 20020717 (1.0) and it worked for every quality ! So not every 1.0-encoded file fails. See YeppGavDetails for details about the files.

OK. I've done extensive tests and I can confirm what Saxifrage suggested : there is indeed a buffer overflow in the tag handling ! When the framing bit of the tag header is at offset >= 0x18C, it fails. If it is at exactly 0x18C, it reboots or freezes. If it is at offset > 0x18C, it always freezes. This was tested with firmware 1.101 and vorbis encoder 1.0.
The file encoded using libVorbis 1.0 in the table above has a too large tag and that's why it fails.
In summary, the Yepp can only play Vorbis when it is encoded with libVorbis version >= 1.0rc2 AND when the framing bit of the tag header is at offset < 0x18C.


I've got this model with 256MB of flash memory, and unlike above, I ran into problems when I tried to play very-low-bitrate files (< 64kbps, CD format). I encoded them using aoTuV-beta4 experiment version from aoyumi (which creates (or should create) perfectly standard and conforming files), using command-line oggenc under linux. The qualities I used for these problematic files are -q-1 (~45kbps) and -q-2 (~32kbps), and when the player tries to open the file it freezes, but for qualities from -q0 it works perfectly.

Apart from that, I've had no real problem before, using mostly -q6 files from RC3 and 1.0, without tags or with standard ones. Sometimes the sound is distorted a lot for a few tenths of seconds, it seems to be related to bitrate peaks (applauds, etc.).

Hope this will be useful, anyway thanks for the investigations on this player, I also realized the lack of information on this player's ogg support. Superdupont 16:49, 2 Aug 2005 (PDT)

Edit: firmware version: 1.543

The YP-T6 seems to be almost identical to the Trekstor i.Beat Cube.

The YP-T6s sold in the US sports an FM Radio with 16 saved settings and automatic station search. Recording from a radio program to MP3 is possible. At least the German version of the YP-T6 does not have an built-in tuner.

The German web site has moved it from from "MP3 players" to the Archived MP3 players section, while the US and UK site lists it as regular model. I don't know if this indicates that Samsung is about to stop production of the T6 or if there have been problems on the German market (like restrictive radio emission laws, see built-in tuner section above).


The Samsung YP-T9 series supports both, UMS and MTP, depending on the firmware. The devices shipped in the USA and Europe are usually MTP devices, the firmware versions available from Samsung Europe or Samsung US are also MTP only (identifiable by the string 'MTP' in the file name).

However, the devices can be flashed with the firmware from Singapore or Australia: that firmware is UMS and can be downloaded from Samsung Singapore or Samsung Australia (identifiable by the string 'UMS' in the file name). Besides that feature the firmware is the same: even the European languages are supported!

Besides the fact that firmware updates are on the users own risk the only problem left is that there might be different model numbers: for example the European model YP-T9JQB is not listed at Samsung Australia. However, a firmware for the model YP-T9BQB worked without problems (YMMV!).

The upload of the firmware can be done with Linux as well:

$ mtp-sendfile SYSDATA.bin /
$ mtp-sendfile MUON.ROM /

Further comments

Actually the firmware is available in two different versions: MTP and UMS. Current (May '07) players have 1.67 firmware, with the US version being MTP. Reflashing with UMS firmware (eg file "" from Samsung's download site) allows it to work as USB Mass Storage and recognize .ogg files. See my post on LWN for more detail. -- AJWM 13:58, 17 May 2007 (PDT)

Here's a link to the above firmware: --AJWM 18:00, 17 May 2007 (PDT)

Note: There is a ton of very useful T9 "how to" information, including working (as of this writing) links to firmware, in the "sticky" forum threads on here. --Gary8 14:19, 3 November 2009 (UTC)


I'am not sure what's inside this player. May be it's a STMP3505. With firmware 1.200 it plays Ogg Vorbis, but not at very low bitrates(-q-1 and -q-2).nostromo 4 Nov 2005.

Firmware 1.200 is a bit difficult to find, googling by file name ( gets a single relevant result: Korean page with a link to the updater. If it disappears, contact me (inejge) via this site (E-mail this user on the linked page).

The new firmware is much nicer than the previous release (my player came with V1.024):

  • It plays OGGs, starting with -q0.
  • The main screen is better organized.
  • Menus are cleaned up (and with more eye candy).
  • Non-ASCII characters in tags are displayed properly (tested with OGG).

Note: if you are encoding OGGs at -q0, don't try to set the lower bitrate limit to 64 kb/s -- the player can choke on managed bitrate files. Nominal bitrate is all that counts.

--Inejge 06:32, 12 Dec 2005 (PST)


Firmware 2.242: Plays Vorbis OK with tag support. Tested with aoTuV beta 4.51 and Vorbis between -q2 and -q8 (mostly at -q5; manual claims support from -q0 to -q10), no lockups so far. Experienced unusual distortion at one point of a particular track (loud, percussive synthetic "thunderclap") at -q5, decreasing with increasing -q value; this appears to be caused by a spike in bitrate, solved by passing encoding options

--managed -b160 -M192

--ettlz 07:35, 25 January 2006 (PST)

OK, I've experienced a few (very rare) lockups with firmware 2.242, but nothing major. Has anyone tried the new 3.122 firmware on the YP-U1? I've e-mailed Samsung to ask what changes this makes, but the didn't seem to know much. --Ettlz 13:06, 10 November 2006 (PST)


Firmware 1.301: A YP-U2J out of the box, purchased in the US will not support OGG, even though Samsung's web site claims it does for the YP-U2 product home page. There are lots of firmware from other countries that will allow your YP-U2J to support OGG, but it took me a long time to figure out one that did OGG and had a working FM Radio feature. Other firmwares would not include the FM Radio feature or the FM Radio feature would lock up the YP-U2J as soon as it was started. I did find one however that worked. Note that at the time of this post you will have to agree to the following legal question in order to get an OGG-compatible, FM Radio featured YP-U2J.

Our Global Download Center provides access to downloadable content for Samsung products or services sold throughout the world. Please note that the contents offered through the Global Download Center may not be suitable for products or services available in your country. Samsung assume no responsibility, and shall not be liable, in connection with whether any such products or services will be appropriate, functional or supported for the Samsung products or services available in your country.

I was successful with the 1.301 firmware version which I obtained via the following method from the website:

1) From a browser go to
2) Click on Support, then Download Center.
3) Select your model by searching for YP-U2JXB.
4) Note at the present (7/31/2006) there is not a newer offered firmware for this selected model. However there is still the ability to get a firmware release for it. So from this page click on "the global download center" link.
5) Pop-up windows will open and if you agree to the legal question which is mentioned above then click Accept.
6) Now narrow down to your model by selecting the following from the scrollable panes from left to right:
     |TV, Video & Audio|
     |Digital Audio Player|
7) In the new page click Firmware.
8) Click the link for YP-U2XB Firmware upgrade (ver.1.301).
9) Run the setup.exe from the zip to install the YP-U2 updater software.
10) Follow the zipped instructions for how to flash the firmware.

- esterud

Awesome! Other improvements with version 1.301 are:
1 It is no longer an MPT device (that I can tell) so you can now load the YP-U2 with drag and drop on Windows XP Explorer. Windows Media Player still works the same.
2 It fixes the play only in alphabetic ID3 label name, not track order bug. The play order can now be arranged in filename order using numerics - messy playlists no longer required.
- holymakeral

This firmware is no longer available from samsung, at least by following the instructions above, browsing from where I am. I called Samsung customer support and was told that Microsoft has made it a criteria for "Janus/ MPP" compliance that portable players sold in the USA must NOT support Ogg playback, so any talk of playing Ogg files on their website is untrue if you buy in the US. Terrible.

- zebedee

This criteria apparently was rescinded in late 2005 after an antitrust judge blew her lid.

- n8evv

As of 9.14.2006, this firmware is still available via the instructions above. Make sure you follow the "global download center" link near the bottom of the page as mentioned in Step 4.
Also, the new firmware makes this a standard USB thumbdrive (not an MPT device), so linux (and windows) recognizes it easily and it does, in fact play ogg. (zebedee is correct if you only consider the stock firmware.)
- wwonderllama

If the updater endlessly keeps searching for your hardware, be sure to read the help file in the updater zip file. You must plug in the YP-U2, hold the play button on the top of the device, and use a pin or something to punch the reset button on the end. Keep holding the play button while it updates.

- van

This firmware also works on the YP-U2JQB/XAA, allowing it to appear as a standard USB thumbdrive, and also fixing the playback order issue that it has. (the actual version of American firmware my player came with was higher than the European version linked above, but the lower European version has better features and less bugs...)


29 September 2006. I used a 'newer' version on a US model YP-U2J ZW. Ver. No. 1.305. Again, be sure to 'press' play and 'reset' when the installer searches for the drive. Love that it is a standard USB thumbdrive, and files can be played/organized by folders.

04 October 2006 Just bought an YP-U2JQB/XAA yesterday and got the "International" YP-U2 firmware flashed without a problem (look at the "help" html document in the firmware updater zip file). Love that it plays OGG and shows up under Linux as a USB mass storage device. Amazing little player.

Two complaints:

  • OGG tags don't seem to be working. Has anyone been able to get the player to interpret the OGG tags?
  • Doesn't seem to have any way to upload playlists (with the new firmware). Has anyone been able to do this?


18 October 2006 Brown Bag Admission: Ogg tags (and id3) work if you go Settings->Display->Tag->On (duh!) Still haven't found a way to upload playlists... Considering reverse engineering the PLAYLIST file in the SYSTEM directory...


31 October 2006 I also just bought an YP-U2JQB/XAA (US model), and successfully updated to the 1.305 firmware. Navigation is so much better! Tell you what though; I found an alternate method of getting at the firmware. Go to, and select "Australia" in the Country/Region dropdown at the top of the page. Then choose "Support", and enter the model "YP-U2Z". Then click "Firmware", and there it is. No messy agreements or popups.


2 Nov 2006 YP-U2JQB/XAA 2GB - To get to the 1.301 firmware from the US, I had to go to, type directly in the search box on the front page "yp-u2xb firmware". First search result is "Digital Audio Player Yepp YP-U2XB Firmware", this is the one you want. 1.300 and 1.301 firmware are available there. I got 1.301 .

Ogg playback, FM radio works, USB mass storage, all good. However... The unit seems subject to random restarts with this firmware. I never tried it with the factory original (Stupid PlaysForSure!) firmware. It has restarted itself right in the middle of a song, no button presses or anything. When it comes back up, it is in the state that it was when it last started up, IE it forgot about the song it was in the middle of playing when it crashed. This has happened about twice in ~5 hours of use. I'll try the 1.305 when I get a chance. Kwan3217 08:19, 2 November 2006 (PST)

November 9, 2006 As jspeigel and Kwan3217 mentioned, the US XAA model will also support this firmware. It changes the functionality significantly. Some things I didn't see mentioned is that it no longer navigates by ID3 tags, but filenames and folders. I wish it used the ID3 tags and paid attention to the track ordering, but I'll take the filenames over alphabetic ID3 navigation anyday. :)

Also, the Playlist funtion in this firmware is essentially the same as the Favorites function in the previous firmware. When you are viewing tracks in a track listing, you can press the user defined key and it will star the track which adds it to your Playlist. Apparently this device only supports a single playlist, but I did notice if you hit the play button on a folder it will dynamically create a playlist out of the files in that folder, so it serves the same funtion as playlists on the old firmware. So, jspeigel, no need to reverse engineer the playlist function. :)

Also, Kwan3217, I had a couple of random restarts with the original firmware, so it may be a hardware or file problem, and as you mentioned, when it restarted, it came back with the volume and track position at the same place it was when I last turned it on, so I assume it writes that info out when it shuts down gracefully.

Anybody looking into hacking the firmware to get something like Rockbox on this player?


November 17, 2006

I purchased a YP-U2JZW/XAA from Target last night (Clearance 39.90!) and thanks to this page was able to download the firmware mentioned, although the new firmware is 1.351. I just finished flashing the update and am happy to report it works great. I haven't tried an OGG file yet, as I don't use OGG much, but I flashed it mainly to enable UMS mode so that I can drag and drop from iTunes for Windows, and it works wonderfully. I do miss the ability to browse via ID3 tags, but Folders/Filenames will have to do until someone can edit the firmware.

I've had no resets so far, maybe 1.351 fixes the reboots.

Thanks for this wiki page!


November 17, 2006

Thanks for the heads-up about the release of 1.351. I've confirmed that this is available via Samsung's Australian support website. I'd kill for a changelog.


22 December 2006

I read this page with hope...and then crashed-and-burned. I downloaded the firmware updates recommended for YP-U2J (mine is YP-U2JZW/XAA) and followed the play-reset instructions. It crashes Windows every time. Now, I can't get the device to be recognized and I can't install an earlier firmware version. Has anyone else had a problem like this? Has anyone else tried to do this via emulation software? (I'm a Linux person with VMWare to run Windows.)

I'll report back if I have any success recovering from this.


30 December 2006

I got a player with a 1.136 firmware. The player did not work under Linux, or play OGG files. After following your instructions (using 1.351) it worked as a USB drive and played Vorbis files. Just wanted to say thanks. Also just curious, does anyone know why the US version has Org Vorbis disabled, and why the new US Firmware stopped the player from being used as a USB drive?

22 January 2007

I updated my yp-u2zw-els 1gb with the latest 2.612-eu firmware, hoping to be able to sort the files in a decent way. No improvement there. So I mailed samsung support about the disability to use tags or filenames. They actually replied, answering that you have to use the first 5 characters of your filenames to get the sorting done. DUH! Are they using DOS filenames scheme inside? (5.3=8) But that is actually correct! So forget about artist or album or trackname, simply put the tracknumber in front of it. Took me months to finally figure that one out! BTW, Ogg works fine with that firmware.


urls to the firmware

The updates can be found here:

Version 1.300

Version 1.351

Both are supposedly the international version despite the "" at the end of file one. I have not installed either of these yet, I'll post my results later. -WeFeeling

I just purchased a YP-U2JZW and the update program was not finding the device. Perhaps this is a stupid error on my part, but the technique I used to get the device to be recognized is the following: hold down reset and play (once the unit is plugged in) and then let go of reset while still holding on to play. This trick allowed the update program to find the device. Additionally, my unit had a more recent firmware 1.360 or something along those lines, however flashing it to the 1.351 fixed all my problems and the device acts as a USB flash drive. So, it appears that they have a more recent firmware out there, but it's just as limited as the old ones. Go with the 1.351. Alexkraemer 23:42, 29 December 2006 (PST)

More success with 2GB YP-U2J

December 12, 2006

I bought a YP-U2JQB/XAA (2GB, USA) yesterday and wanted to get it to work with linux as a USB drive (without MTP). Currently Samsung's Global Downlad Center has the following firmware files for varous YP-U2 models:






I installed v1.351 on it from a windows computer and it is working fine in linux as a usb storage (UMS) device. My laptop is old and does not have USB 2.0, so v1.351 supports USB 1. I followed the instructions for upgrading the firmware in the html file within the zip file. Ogg files play fine.

- Brishchik .

January 8, 2006

Purchased a Samsung YP-U2JQB/XAA w/firmware version 1.136.876 (all USB ports used were 1.0)

Ubuntu Dapper Drake would not see it. Well, it didn't auto mount and open as a folder. However, I didn't try pressing/holding play and poking reset.

Windows XP would only show it as a portable device and the only way I could get music on it was with Windows Media Player.

I downloaded the above file, '' and just before flashing it, XP allowed me to access it like a thumb drive.

I neglected to copy the files before erasing them (If you saved them, could I get a copy? I'm curious to see what they do.) and putting the downloaded firmware ver. 1.300 on it using XP. I wonder if they allow you to play by Genre or something, but if thats the case, they were probably auto-created by WMP.

Windows sees it as a portable USB drive now and ogg files work, though I didn't test them before.

When I plugged it into the USB extension cord Ubuntu would mount it, but several seconds later it would disappear (repeatedly). Plugging it directly into the same port worked fine, though. Oddly, this doesn't happen with my other usb stuff (mini HD, flash drives, external HD case, etc.)

Radio, mic, and all the settings seem to work. (btw, pressing *USER when listening to a radio preset gives you the option to remove it from the preset list.)

It no longer gives you the option to play by Author/CD/Genre anymore, but hitting play when a folder is selected creates a temporary "playlist" of anything in that folder or in sub folders. So you can play a branch of folders (but not the contents of the folder without it's sub folders). Also, this isn't a playlist that will show up under "Playlist."

It plays in order of file name, rather then the order songs were transferred. Again though, I didn't test this before.

I meant to put the '' firmware on it, but accidentally unzipped & installed the other. Any reason to use the ver1351_OC over ver1300_KOR?

Any complaints I have are very minor and have nothing to do with firmware/software (at this point).

- Saxywolf

15 February 2007

Samsung's tech support told me tonight that as of late January, the latest firmware corrects the problems with Windows Media Player 11. (The January date obviously is wrong--the firmware version the tech support agent had me download was 1.136, which someone on here reported getting on a new player at the end of December.) Under this (MTP) firmware version, I briefly got the player to work, and when I did, it actually showed up under Removable Drives rather than Portable Devices, meaning I was able to drag and drop under Windows Explorer/My Computer. However, it was showing up as a "Recovery Device", and so I'm not sure it would show up as a removable drive if it were working properly.

I was never able to get the player to work properly on my computer using the MTP firmware: when it was plugged in, it just connected and disconnected itself every five seconds, also showing up as "MTP Device". I got it to work on one computer in a classroom where I teach, but not on my office computer (which for some reason required admin privileges to install it--this may be one big advantage of UMS over MTP). I therefore upgraded it to one of the latest UMS version.

The latest UMS versions will not not allow you to upgrade from the MTP version (at least, not 1.136)--I guess Samsung has decided that if you buy the MTP version, you're stuck with it. However, I was able to flash to one of the older UMS versions, 1.352, and after that I was able to flash to one of the latest UMS versions (2.161). It doesn't seem to matter which UMS version you're upgrading from--I went from 1.352 ("EU") to 2.161 ("OC"--I had originally found this one by telling the support site I was in Australia) without any problem.

Therefore, if you want to change over from MTP to UMS, you should first upgraded to one of the 1.35x UMS versions, then unintall the installer, and upgrade to one of the 2.16x versions. I've included the URL's to these new versions below (I'm sure there's also a Korean version as well--if you want to search for it on the Samsung Global Download Center, the version number should be 2.160).


16 February 2007

I had a similar experience to the 15 Feb 07 poster -- I got a player (YP-U2JZW) with the version 1.136 firmware installed. Unfortunately, since this is an MTP firmware, SyncToy would not work to sync my podcasts. I converted to 1.351 ("OC") and then to 2.161 ("OC"), either of which are UMS firmware versions. Unfortunately, the only navigation options for these firmwares are via folder heirarchy or via a playlist (i.e. not by track/artist/album/genre). They also do not include the "favorites" option. But they do allow for deleting files via Settings->System. I didn't notice any other major differences.

I had the same problem with the player showing up as a "Player Recovery Device Class" while I was trying the hold play/press reset trick to get the firmware updater to work. In order to get around this, I plugged in the device and then held play & pressed reset without the firmware updater running. Once Windows XP popped up the "Found New Hardware" wizard, I hit "Next" and allowed the wizard to complete. Only then did I launch the updater, and it worked like a charm. If you try to cancel the "Found New Hardware" wizard, the device will not be recognized by the updater. And if you run the "Found New Hardware" wizard at the same time as the updater, they both seem to hang without making progress.

17 February 2007

Just one addendum: once you change to UMS, if you're in the U.S. you need to remember to go into the Radio Settings to set the FM tuner for USA/Korea (though mine seemed to be working fine before I changed it).


19 February 2007

Just bought a YP-U2JZW. It came with 1.136, which is the only firmware the Samsung seems to be offering now. In my attempts to install one of the firmwares mentioned above, the updater software would not get past initializing or searching for device, which would leave the device inoperable (recognizable as USB drive but player interface would not turn on). I could flash it back to the 1.136 firmware by unistalling the updater and installing the 1.136 updater. What I did to finally get the firmware to work was use the 1.136 updater and let it recognize the device. Then I copied the binary files from the 1.351 firmware over to the c:\Program Files\Samsung\YP-U2J\ folder (you can check this by clicking the details button on the updater). Only then did I click on start. I check system>setting>about and now have 1.351 installed and the ability to play all my .ogg files. Hope this helps someone who runs up against the same problem as me.

- elpresidente

March 6, 2006 Using 1.351 on a YPU2J, the player sorts files by MP3 tags (title?) instead of by filename. Very annoying for my use. Anyone have a fix. Is there some hidden setting, or do I have to find different firmware?



14 March 2007

I bought a YP-U2JQB/XAA; and here's what I had to do to get non-crippled firmware installed after several hours of trying.

The latest US firmware updater is necessary. I went to Samsung's website, searched for 'YP-U2JQB/XAA firmware', and downloaded the installer.

Downloaded the 2.162-EU installer from the link above (

Install the latest US firmware updater.

Start the firmware update process. In my case the dialog box with the progress bars said that the current firmware version is 1.136, and the version to be installed is 1.136. Fortunately it looks like the messy business of using three hands to hold the 'play' button, push the reset button with a tiny pin, and start the firmware installer all at the same time, isn't necessary (or at least wasn't in my case).

Don't install the firmware yet. Take the files out of the Binaries directory of the v2.162 zipfile, and put them in place of the same files for the 1.136 installer (probably under C:\Documents and Settings\Samsung\YP-U2\). You *must* do this after the installer has recognized the device, but before the firmware is actually installed. It doesn't seem to work otherwise.

Now continue the firmware update process. This should work.

My Jens of Sweden MP-400 (no longer available unfortunately) does the same things as this device (albeit with less capacity), in 2/3rds the size, with far more configurability and a better constructed case. I'd skip the Samsung device unless you really need something this small and can't find a better alternative (check eBay for Jens of Sweden's older players).

I followed the steps from the previous post and it worked like a charm. I thought my player was dead. They key, as stated above, it to get the recover class installed first and they launch the updater. One note, usually the files are located in c:\program files\samsun\yp-u2. I believe there was a type above (c:\documents and settings vs c:\program files). Non the less, the last post was very, very helpful. Thanks guys. - Keith

9 May 2007

I just noticed the new 2.162 firmware. Does anyone know if there are any real functional differences between 2.162 (UMS) and the old 1.351 (UMS)? Is there any reason to upgrade?


I had varying success with what is posted here. I got the device to function like a drive but lost my FM radio function. I was willing to live with that but decided to dig a little further. Going to the Samsung Hong Kong site I was able to find the version 2.165. Don't worry about matching model numbers; just pick the play that looks like yours. I found this version gave me the right functionality and the FM tuner. Vorbis OGG works too. I followed the steps of, attach the drive, put it into recovery mode, then load the installation software. The Samsung global download site suggested here only offered version 1.136. BTW, while I did the firmware on a computer with XP, I now regularly use it on a Windows 2000 computer.

-kozel 14 May 2007

2007 Augus 18

I just bought a refurbished YP-U2J or YP-U2JQB (the first name is printed on the case, the second is printed on a stick-on label).

The firmware is 1.136 and it does not support UMS. I wish to update to the latest that supports UMS.

How can I tell which versions will work with my player? Is mine the same as YP-U2JQB/XAA? Looking at the Australian download centre, there is only firmware for the YP-U2X and the YP-U2Z. Google tells me that the X has 512M of flash and the Z has 1G. My player has 2G. So neither seems like a proper match.

The Australian site offers 2.161 for Win 98/2K/XP user and 2.211 for Win 2000/XP/Vista users. Both models get the same firmware version; at least for 2.211, both .zip files are identical. Version suffix OC_th. "common language (SOUTH AMERICA, ASIA PACIFIC, MIDDLE EAST, AFRICA, MEXICO, INDIA, JAPAN)"

The Singapore site has more models but the same firmware version numbers as Australia.

The United Kingdom site offers 2.162 and 2.212. Version suffix EU (Europe?). "common language (list of lots of European countries and Swaziland but not France)".

The Hong Kong site offers 2.215. Version suffix CH (Chinese?). "common language (CHINA, HONG KONG, TAIWAN)"

I'm going to go with OC_th but I wonder if the EU version would be better. Hugh 22:15, 18 August 2007 (PDT)

kozel 29 August 2007

I just bought another player, a refurb 2gb, sticker says YP-U2JQB. I went to the Hong Kong English web site and picked the model YP-U2ZB and downloaded the 2.165 firmware and it installed fine and it's in English. I subsequently went back and downloaded the 2.215 firmware and installed that over the 2.165 and that works fine as well. The only issue with installing the 2.215 firmware is that I didn't have to put the unit into recovery to start the process; but after an inordinate long time of repeating start to end green progress bar display, it looks like the unit put itself into recovery mode and then the install completed. I thought it was in a loop and I was afraid to interrupt it and just let it run. You may want to place the unit into recovery mode before executing the upgrade software. If you are upgrading from the standard US firmware, you will have to put the unit into recovery anyway. BTW, while I did the firmware on an XP, the drive is easily recognized on Win 2000 after the upgrade.

Could someone please post the URL (Hong Kong?) for the most up-to-date firmware? Thanks. --M-K, 11-29-07

kozel 14 Dec 2007

I can't really provide the url. Go to to get to the Hong Kong English site. Pick the support tab and under 'type 2' pick the options for 'TV video audio' then 'digitial audio player' then 'mp3' then for model try the 'YP-U2ZB' and then select the tab for 'firmware' and you'll see the 2 files.

Spacemanspiff 20 Feb 2008

I just wanted to thank kozel. I followed the directions and was able to get a UMS device and it can read ID3 tags. great work! the newest HK firmware allows that. and FM radio works fine in the US mode. thanks! :)

How bout Windows 2000 Pro ?

Any hope of this device working on Windows 2000 Pro ??

all the computers at my work run Win 2K - and this is my primary place I would use it. I put it in and it came up and tried to install it auto - then had me restart. Now nothing - it won't show up in my computer or anything. ??


Dave Platt wrote about the YP-U3: bought one in September 2007. So far it has played my Vorbis files flawlessly - I've used -q3 (averaging around 100kbit/second) and -q6 (192kbit/second nominal). Track switching is not gapless but is only a couple of tenths of a second. The US version is MTP rather than UMS, so I had to download and install libmtp and Amarok and tweak my Linux udev configuration to be able to see and access the device. Vorbis tags are correctly displayed during playback, and Amarok correctly extracts the tag information and feeds it to the YP-U3 for indexing purposes when the tracks are downloaded. Doesn't seem to be possible to re-flash it with the "universal" international firmware (odd-numbered versions) which are UMS-based. I've read reports which suggest that the UMS versions will display Vorbis tags during playback but won't extract them from the files for indexing purposes, which would make the player harder to use with Vorbis tracks!


I'm n8evv and I have one. It plays 160 kbit/sec vorbis, but not 45 kbit/sec. Need to test in between, and to see if it's the age of the encoder or the bitrate. (As disks got bigger, I bumped up my bitrate.) Play order is unclear and seems to jump between folders. The 45 kbit/sec tracks are just skipped. I don't use the bundled Windows software; I mount the device as a Linux disk as /dev/sda1.

My machine came with 2.201 firmware. Samsung offers 2.301 firmware as of 12 Jan 2007, but doesn't offer any backlevel firmware so I'm nervous about changing anything. There are no firmware release notes.


After having success with the firmware upgrading instructions listed elsewhere on this page for my YP-U2JQB/XAA, I bought a YP-F2JXB/XAA for my wife. I was originally successful upgrading it to the YP-F2Z firmware v1.503, but that lost the radio. I then successfully [up|down]graded to the YP-F2X v1.451 firmware with radio, playlist and all.

The tricky part is getting into the "recovery mode". The reset button is covered by the included USB cable. I had to make a little tool, bending the tip of a pin with a pair of needle nose pliers.

OGG disease

Guys, we of Xiph really appreciate all the work of every one of you that is collecting info on the many hardware players out there, but personally, I would appreciate if you would stop saying OGG; it's not an acronym. Actually, do not mention Ogg just by itself: either use Ogg Vorbis, or just Vorbis.

There's so many formats using the Ogg container that not making clear that Ogg != Vorbis will only cause problems and confusion. Please keep that in mind.--Saoshyant 07:11, 21 February 2007 (PST)


From (you can download sample files there to hear the problems on you own T10 or maybe other Yepp)

I've found some decoding problems on this device like there used to be on the Cowon iAudio D2.

It seems that for some songs with heavy bass notes when encoded as Ogg Vorbis, playback has this extra high hat sound on it, but the MP3 doesn't. The Ogg Vorbis files plays back fine on the PC.

If I use an mp3 or an aac (m4a) file, I don't hear it at all. I also don't hear it when playing it from my PC using Foobar or Winamp.

The main thing I can hear is once the track gets going, in-between the beats I hear a high hat-like sound. Note however that I can't hear this noise when I play the exact same file in WinAMP or foobar (or as an mp3 on the T10)... it's sending me crazy! I also checked playback using the original CD on a pro quality CD player's headphone output (CDJ200), and couldn't hear it.

I think there is a problem with the Ogg Vorbis decoder on the T10, and have emailed Samsung Australia support about it.

The ogg files were encoded using foobar/OggEnc v2.85 (libvorbis 1.2.0 [aoTuVb5.5]). My firmware is v3.06.