Talk:PortablePlayers

From XiphWiki

Revision as of 16:29, 30 April 2005 by Gav (Talk | contribs)
Jump to: navigation, search

There are many more portable players by TrekStor than the i.beat 500 supporting ogg vorbis.

Please add products to the main page.


I would like to know which Players can record in OGG?! -- 217.186.150.213 17:03, 26 Dec 2004 (PST)

Pretec Allegro may need firmware update

I recently purchased a Pretec Allegro, but was unable to play Oggs for three months, until the firmware update was made available on 14 or 15 March 2005. Now it works well! (So far, listening to -q3 Oggs). I'd hope that units purchased after this date already has the firmware update, but you never know. Installing the update is as simple as placing the .rom on the USB-storage-device media (eg flash disk), starting up the unit, and pressing the play button. -- Hugo van der Merwe

Any player with SD-Cards

Every single ogg-capable portable player out there seems to come with built-in flash memory. Which is stupid, because I don't want to fire up my computer and plug in the player every time I get tired of the tracks on my player. Plus flash memory has a limited lifetime (write cycles) and so does your player with built-in memory. The same applies for built-in rechargable batteries.

Now when would you ever need to buy your second device without any moving parts if you could just change flash memory and batteries? Ok, that's the industrie's point of view but not mine. I want to go on vacation with music and batteries for one week of non-stop music - without a power source or computer nearby.

So, any hint to where I might find a portable audio player that can play back ogg vorbis files and uses SD flash cards (and preferably AAA-batteries) would be greatly appreciated.


The Pretec Allegro is not the slickest player out there, it's LCD backlight seems to give off a high-pitched whine, which not everyone can hear (it kind-of screams in my ears though, so I put the backlight timer on 1 second so it doesn't scream too long). It is, however, the only one I now know of that can play Oggs, and uses removable media. If you want a nicely portable device, you have to use Pretec's "iDisk tiny" usb flash disk, the only thing that will fit inside. You can also, however, connect some USB SD-card reader with it's cable, then listen to Oggs off of SD. A little unwieldy, but, it works, and is the only thing *I* know of. (I stopped following developments in December though, when I bought it...)

Samsung's Yepp Ogg Vorbis support

JoshuaRodman wrote in the article under the Samsung Yepp flash-based player entry (I've moved it here and inserted a link to this take page instead):

I received such a unit. It plays oggs encodd at -q 4, 5 and 6 without error that I have noticed. However it seems underdocumented. It plays the files in an order which is neither alpha sorted nor numeric sorted, and it does not support ogg tags. -- JoshuaRodman (March 28, 2005)
I've investigated more. Some music encoded at even -q 5 will break up or cause difficulty. I suspect these pieces have bitrate spikes. As for the ordering, the YP-T7 plays files in 'readdir' order. That is it does not sort the files out of the filesystem at all. In practice, this means it will play the files in the order that you add them to the directory. If you are a windows user dragging and dropping the files onto the player, this problem will not affect you. A linux or possible Mac user may need to do minor scripting to alleviate this issue. --JoshuaRodman (April 13, 2005)
Two questions: 1) are ogg tags not being displayed even when the Tag option is toggle to On in the settings menu? 2) how does it handle -q 4 and -q 6 — is it just -q 5, or is it -q 5 and higher/lower? — Saxifrage 01:07, 14 Apr 2005 (PDT)

I just bought one of these and I'm baffled by its erratic Ogg support. Firmware version 1.541 seems to support tags just fine, though I haven't noticed the alpha-sorting issue (haven't looked). However, I find that it can't play all my Ogg files (freezes when it tries to load the file), and there's nothing systematic that I've found to account for this. It plays some files I encoded Jan 29-Jan 30, 2005, but there are files that don't work before and after that date. The files that work so far were encoded with nominal bitrates of 128 and 192, while others that don't work were at 160. All encodings have used the same program (Grip under Linux). Ogg files that I've encoded with oggenc directly for testing purposes at 160 nominal bitrate work just fine. There's just something about most of my existing files.

I've emailed a support request to Samsung Canada, so I'll report what I find out then. Meanwhile I'm doing a bunch of rips with Grip to test different nominal bitrates. Saxifrage 10:53, 12 Apr 2005 (PDT)

Results from my experiments with different nominal bitrates are summarised in this table:
YP-T6 Ogg Vorbis support
  Tags none tag* tag + replaygain replaygain
Bitrate (nominal)          
128   works works works  ?
160   works works freezes works
192   works works works  ?
* "tag" means just the regular complement of artist, album, title, year, and genre.
"?" indicates that the case was not tested
My conclusion is that the Samsung YP-T6 can't handle Ogg Vorbis files encoded at 160 nominal bitrate if ReplayGain tags are applied to the file. Note too that I tested a file without real RG tags, but with the normal tags plus tags with different names than the standard RG tags but with the same name-length and same length of arguments; this was to isolate whether it was a ReplayGain-specific bug or a general tag-handling bug. Thus, I suspect that the problem is a buffer overflow in tag code of the firmware. Note that I have only tested files encoded with nominal bitrates, not files encoded with oggenc's quality settings.
The few files in my collection that have worked were encoded at different bitrates (either 128 or 192), but unfortunately the vast majority are 160, and I need ReplayGain to be able to listen to my collection on the PC without constantly changing the volume. As a workaround I may write a script to strip the ReplayGain tags as they're moved to my player, but this rather sucks. — Saxifrage 12:36, 12 Apr 2005 (PDT)
 
 
I (Gav) own a Yepp MT-6X and I don't come to the same conclusions. I tried to remove the Gain tags and it didn't improve anything. Here are some tests I made :
YP-MT6X Ogg Vorbis support
Encoder version Filename Nominal bitrate Playback test
Xiphophorus libVorbis I 20000508 (1.0 beta 1 or beta 2) 01 - In Tenebris.ogg unset (160 kbps) KO
Xiphophorus libVorbis I 20001031 (1.0 beta 3) 01 - A Day Without Rain.ogg 160 kbps KO
Xiphophorus libVorbis I 20010225 (1.0 beta 4) 01 - Sunday Bloody Sunday.ogg 128 kbps KO
Xiphophorus libVorbis I 20010615 (1.0 rc1) 01 - Remede.ogg 128 kbps KO
Xiphophorus libVorbis I 20010813 (1.0 rc2) 01 - Devil's Haircut.ogg 192 kbps OK
Xiphophorus libVorbis I 20011231 (1.0 rc3) 01 - Encore Une Chance.ogg 112 kbps OK
Xiph.Org libVorbis I 20020717 (1.0) 01 - Inferno (Unleash The Fire).ogg 160 kbps KO
Xiph.Org libVorbis I 20030909 (1.0.1) 01 - You Will Be a Hot Dancer.ogg 128.kbps OK

Yes, a 1.0 file fails... I also tested a 8 second file encoded at q1,q2,...,q10 using 20020717 (1.0) and it worked for every quality ! So not every 1.0-encoded file fails.

Personal tools


Main Page

Xiph.Org Projects

Audio—

Video—

Text—

Container—

Streaming—